How do I manually change the image path?


#1

Hi there,

I recently migrated from Wordpress. The process was:

  • Upload images to Cloudinary
  • Upload the exported json from WP into Ghost

This worked fine, except my cloudinary image links are all http (not https). So this gives mixed content errors all over the place.

Any ideas on how I can manually fix this?

(It’s too late for me to re-upload the JSON after doing a find & replace. If I did it now, it would create all the authors and posts again… tried it already. had to roll-back)

Thanks!


#2

It’s too late for me to re-upload the JSON after doing a find & replace. If I did it now, it would create all the authors and posts again… tried it already. had to roll-back)

This is the only viable way to do a find and replace. If you export, do your find & replace, then use the “delete all content” button, it will delete all of your posts, tags and authors.

Then if you re-import, your content will not be duplicated.


#3

Noted,
thanks Hannah.
I’ll try out this solution.

Another question - what would happen turn off the “Use dated permalinks” feature?
Would it modify previous posts in any way? Or would it only apply to the new posts?

Thanks!


#4

The setting is currently global, so all of your URLs would change. You’d need to use the redirect feature to setup 301 redirects for the old URL structure to the new one.


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.