How setup email

Hi dear community,

I have 2 tasks with my email.

  1. I need to connect Mailgun and Ghost to provide notifications and other stuff. I do everything regarding this article: Configuration - Adapt your publication to suit your needs
    I’ve did steps on Mailgun side without any problems. Also here is a screenshot of my json config

But when i try to subscribe to my site, i see an error

I thought the problem is in empty form here, in admin panel of the Ghost (because in official Ghost guide there is no any info about this step).
I’ve added API key key (from Mailgun) and Mailgun domain, but still no progress.


  1. Maybe the source of problem is in my Digital Ocean email setup? I did nothing at this side. Should i create at hosting some email entity?

  2. Is it possible to use at the same time Mailgun and Gmail? As far as i need Mailgun only for sending notifications and Gmail - to read users letters and reply them. But i’ve heard it’s not very good to use them at once.

Before we troubleshoot further: You /did/ restart Ghost after changing the config.json file, right? :slight_smile: If you didn’t, please go do that first.

The mailgun settings you snapshotted above (from the Ghost settings) are for newsletter sending. They don’t impact transactional email, which includes sending magic links (what you’re trying to do here).

Ghost is not going to receive email for you and let you read it. You don’t set up your inbound email with Ghost. (That seems to be what you’re asking in #2?)

Right you are, i’ve made restart yet.

Finally, i can mark 3 tasks and their possible solutions.

  1. Setup the transactional emails. As i understood, it’s necessary to replace my current config.production.json file with another parameters?
  2. Setup notification emails. Just keep the current piece of code in config.production.json?
  3. I’ve got that Ghost is not connected with regular email service like Gmail, Outlook etc. Just wanted to doublecheck about possible conflicts because of using Mailgun and other services. Ok, sorry, this question i have to solve on my own.

I’ve even purchased $35 per month plan because there were different issues in other topics because of free version. (Subscribe Failed to send magic link email Error)

Also i changed the port… But nothing helped. Can you please check my preferences once again as i modified’em?

Try running the swaks tool - search the forum for details.

Hello, community!
I’ve tried swak tools and found out the problem in a connection timeout.
How can i solve this problem?

And here my updated setup file

Uffff, i’ve found a solution (changed port from 465 to 587).
Now users can login/register at the site and get confirmation emails.
The only problem left - when user open confirmation email, he get warning about insecure connection.

Should i fix it with a string:
“secure”: true, instead of
“secure”: false,
in config.production.json?

Do i need something else?

The same problem (warning about suspicious connection after user clicks confirmation link) appears in both situations:
A) 465 port, secured connection, no TLS
B) 587 port, no secured connection, switched on TLS

I don’t read Russian and I can’t Google Translate an image, but the error message seems to say that this is an ssl problem with Do you have DNS set up correctly for that domain?

There are directions (although for Ghost Pro) here:

I /suspect/ that you’re not set up correctly in Mailgun, such that it isn’t serving up an SSL certificate for email.yourdomain.tld.

I will check, thanks. It really looks like subdomain doesn’t have ssl certificates

1 Like

That domain should be set up as a cname for mailgun, so mailgun would provide the ssl for it.


Thank you!

I found a solution!
I just need to change tracking protocol from http to https in Mailgun settings.
We can close the ticket now

1 Like