"Update:Ghost Unable to send emails"

Hi, everything else is done. Mailgun is setup and verified, all fine. I’ve been over suggested posts on the forum. SSL is installed and working.

Here’s my config, all valid. No errors in ghost doctor. Been over the documentation, tried all ports, verified keys.

I get the “update:ghost can not send email, read here…”

Using digitalocean. I wonder if its an issue there somewhere, only moved to it today from google cloud.

Use StartTLS on port 587, and set SecureConnection to false, since this is the correct port for secure SMTP.

Also, check that the port is open, and not blocked by a firewall. You can attempt telnet smtp.eu.mailgun.org 587 to confirm the connection.

Cheers, i’ll have a look. Ubuntu firewall is open on all mail ports, there’s no hw wall. I’ll run some test with jnode too, it was late last night, i’d spent 3 hours trying to get mail up.

The only thing that’s comes to mind is that my mail is set up to send from mail.mydomain.com, thats all good on the mailgun end. I feel like theres set up missing on my server though. I created the sub by adding it as mail.mydomain.com in the digitalocean panel, usually i’d add the subdomain via an A on the vanilla domain.

My experience with mail is limited, most of the time i’d set up plesk or even cpanel on a much bigger server, I used to work with wordpress, so that was the easy method. So anything you might have missed, let me know when you have time,.

With Ghost and Node, the setup is essentially using Mailgun as a mail relay, so any config on your server shouldn’t be relevant.

On my server, I have Postfix setup as a mail relay using Mailgun, and this does not require an MX record. This isn’t necessary for Ghost, and I set this up to receive system notifications, e.g., automatic updates.

A sub domain for mail is necessary with Mailgun only if you use the bare domain with another mail service, e.g., Proton Mail. These should not be A records: create MX records. A CNAME may be used with Mailgun for analytics.

Telnet worked. I have the news letter side of things working. I still have the “notification that I cant send emails and I cant sign up as user etc”, so I’m assuming that’s purely an error with the .conf file?

I’ve done it with a subdomain as I’m using another provider to receive the actual emails @mydomain.com.

Your config should look like this:

  "mail": {
    "from": "support@your.domain",
    "transport": "SMTP",
    "options": {
      "host": "smtp.eu.mailgun.org",
      "port": 587,
      "service": "Mailgun",
      "secure": false,
      "requireTLS": true,
      "auth": {
        "user": "postmaster@mg.your.domain",
        "pass": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx-yyyyyyyy-zzzzzzzz"

I’ve tried that and no luck, I then tried EES and Sendgrid, both nothing, really weird.

Go to the following page, and follow the instructions for Swaks (SMTP.)


1 Like

I changed the port on the example to 587, auth error, but fine apart from that. Deleted the user, made a new one and it worked. Copied it over and now it works.

Does swaks initialise the connection in some way? Or is it just a test?

Anyway, thanks for your help, at least I know I can use swaks next time, so it won’t take 6 hours…haha.I got it working via the gmail hack, but thats a crazy way of doing it, would not recommend.

It’s simply a means of testing the connection. Good to hear the issue is resolved.

I think it may have caused an error with my SSL though. It was up and running in every browser tested. Now down in ff,chrome and safari shows neither secure or unsecure.

All online testing websites say it’s installed correctly, https:// and http:// pages load, another bizzare mystery.

Check config.production.json to make sure the domain is using https. If it isn’t, amend and restart Ghost.

It is yeah. I think it might actually be fine as Stripe is working, the icon seems to come and go though. bit odd.Thanks again.

Do you mean the browser secure connection shield, or something else? If you’re getting mixed content, that needs to be resolved.

Yeah, the connection shield. It’s bugged out somehow. I will probably just re-install the whole things as that site is ready to go now.

In better news, I started on a 2nd and the mail activated 1st try and ssl is perfect in every browser.

1 Like