How to change main URL of ghost blog (self hosted)

When I first installed ghost in my VPS, I set up an URL that I am now willing to change.

I’ve found there’s an article that explains how to change the URL of your Ghost blog, however, this doesn’t quite do what I want to.

I’ve followed the steps and I can now see the URL is the one I intend to use when I run ghost ls command and that is https://corner.football, however, when visiting this particular URL, it still re-directs me to the previous URL (https://blogde.futbol)

Instead, the way it should work is, when I visit www.blogde.futbol or blogde.futbol it should redirect me to corner.football, all DNS records are set-up accordingly so I think this has to do with my server config.

I already had SSL certs installed for both domains, including versions with and without www.

Is there any step I’m missing? I would appreciate your assistance as a community.

Many thanks in advance.

Is this the IP address of your ghost setup?
> dig corner.football +short
167.99.197.230

It seems an nginx is redirecting your requests:
> curl https://corner.football -I
HTTP/2 301
server: nginx/1.14.0 (Ubuntu)
date: Wed, 01 Jul 2020 04:51:39 GMT
content-type: text/html
content-length: 194
location: https://blogde.futbol/
strict-transport-security: max-age=63072000; includeSubDomains; preload
x-frame-options: SAMEORIGIN
x-content-type-options: nosniff

Can you check your redirects.json config in ghost:

Best Regards,
Oliver

Welcome @WolfOliver and thank you for your reply.

This is just to confirm that yes, that’s the IP and that my redirects.json file is currently empty.

The examples on the tutorial post you’ve shared cover scenarios in which I would like to redirect posts, but they don’t spefically cover scenarios (as far as I can read) in which the URL I should be getting by visiting corner.football is corner.football and not blogde.futbol.

In other words, the canonical domain (if this is the right terminology) should be corner.football and there should be redirects from www.corner.football, www.blogde.futbol and blogde.futbol onto the first one and I am not sure this can be achieved via redirects.json

Any suggestions will be greatly appreciated!

Just in case anybody finds the thread via organic search, this is the way to fix this:

Big thanks to @akash47!

ps.

You don’t really need filezilla to edit the .conf files, nano editor (if available within your VPS) should do the same job.