Images are not loading in the post

"When writing the post, it worked normally, but when I access the blog after writing, the images are not uploaded properly, and I have to click on the broken image to see the image normally.

I am running the server using Docker. I’m using ‘Ghost:5.87.1’ from Docker Hub as is, and I’m using ‘MySQL 8.0’ for the database."

The problematic post is here. - Nginx Proxy Manager는 신이야

This is what’s called a “mixed content” error. Your post is being served as https, but the images in the srcset have http urls. Most browsers block that. This is why when you go directly to the image, it works fine.

Interestingly, the src attribute on your image is set correctly to https – it’s only the srcset (which most browsers use, unfortunately) that’s wrong.

You might share your Docker compose file (minus secrets) and your Nginx config file.

Thank you very much! Thanks to you, I found out what the problem is and it was solved through a search!
When I added
to code-injection, the image was successfully printed!

1 Like