Importing a json file is giving error

I recently shifted to a new laptop, so I exported all my content to a JSON file and now on my new laptop when i try to import, it gives an error

Import failed

Post: Unable to update nested relation.

[object Object]

  • What’s your URL? NA
  • What version of Ghost are you using? 4.12.1


  • How was Ghost installed and configured? installed through CLI

  • What Node version, database, OS & browser are you using? 14.17.5 , MACOS, Chrome

  • What errors or information do you see in the console?

  • What steps could someone else take to reproduce the issue you’re having? Go to settings → labs → import json

Recently, I faced this issue when I tried to import content exported from Ghost v4.9.1 (server) to Ghost v4.12.1 installed on my local machine. Make sure that the version of both ghost installations is the same.

I’m encountering the same error as I migrate to a new droplet on DigitalOcean from an older version (4.4.0) to a new version (4.12.1). I’m unable to update the 4.4.0 to 4.12.1, so any ideas on how to resolve it?

Can you try upgrading to v4.13.0? This PR was merged which might have been the cause for error.