Importing from 2.38 to 4.2


I’m trying to import from an old ghost installation and I get the message:

Import failed

Value in [settings.type] cannot be blank.


Is this something I can fix?


I’m not sure about the error, but I wonder if you can do more incremental upgrade? maybe try jumping to ghost 3.0 first? If you use docker to setup a test environment at least would be pretty trivial to do so.

Hi @csgeek,
Thank you for the reply.

I tried going to ghost 3 before but I received the exact same error message.
This install uses mariadb and the images are stored on a minio server, but I don’t think this should be the reason for the non-import issue.


When you say you’re importing, are you doing a JSON import aka. export all posts and importing via labs?

The reason i’m asking is because I don’t see anything resembling settings.type in my export.

I haven’t used minio though I have some experience with kubernetes. I don’t think that should cause an issue. The only reason i was mentioning docker is the ease of use when changing versions.

Side note, I export content from 2.38 and imported into 4.0.1 and didn’t see any problems. So at least the bump is possible to go from 2.x to 4.x