Installed Ghost correctly but getting error 404 like its not there?


#1

Ive installed Ghost both through the CLI which was unsuccessful and manually which has worked and over SSH it says it is running but i only get a error 404 as if ghost isn’t there. No errors at all now. Im confident it is installed correctly.
Anyone any ideas?

Ghost Version: Latest
Running Plesk on the server.
Running Ubuntu Server.


#3

Thanks for helping, How can I do this?


#4

@jsbyw You are getting an apache error. Ghost CLI is using and configuring NGINX. There is only one web server which can run on port 80.


#5

Thanks, so how would i go around fixing this?


#6

An option here:

(nginx config’ed as proxy for apache)


#7

This didn’t seem to fix anything


#8

It was just a generic possible solution to check how you run nginx and apache and if you proxy properly nginx listening to 80 to apache listening on another port (8080 for ex) which in return needs to listen for ghost on its own port (2368).


#9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.