Nginx 404 error


#1

When I access my ghost instance by my VPS IP I can access it but when I go through my domain I get this:
404 Not Found
nginx/1.10.3 (Ubuntu)
How can I fix this or what do I need to check? Running it on a DigitalOcean Ubuntu 16.04 server.


#2

It’s better to post your Nginx config (with your domain replaced by “example.com” or something), so that people can help.


#3

It could also be a domain propagation problem, for example. See your current IP from the command line:

host yourdomain.com

#4

Assuming you used the Digital Ocean One Click Deploy, did you run ghost setup afterwards? It sounds like your url isn’t configured properly :thinking:


#5

Yes, I ran ghost setup as well as checked the configuration to make sure my domain was there.


#6

Sorry about that. As soon as I get a chance I will post the config.


#7

Probably you have it in /var/www/ghost/system/files/example.com.conf, with symlinks in /etc/nginx/sites-available and /etc/nginx/sites-enabled.


#8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.