Invalid response from acme-challenge when setting up SSL

Trying to set up SSL for http://www.codymi.ms/ and I get this ProcessError:

Message: Command failed: /bin/sh -c sudo -S -p ‘#node-sudo-passwd#’ /etc/letsencrypt/acme.sh --issue --home /etc/letsencrypt --domain codymi.ms --webroot /var/www/ghost/system/nginx-root --reloadcmd “nginx -s reload” --accountemail [redacted]
[Mon Nov 11 01:02:32 MST 2019] codymi.ms:Verify error:Invalid response from http://codymi.ms/.well-known/acme-challenge/h3ppt4_TXjL2Y13jIedQQYv0V8pp4NXvtDszS_h3nDI [45.79.47.115]:
[Mon Nov 11 01:02:32 MST 2019] Please add ‘–debug’ or ‘–log’ to check more details.
[Mon Nov 11 01:02:32 MST 2019] See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh

[Mon Nov 11 01:02:28 MST 2019] Single domain=‘codymi.ms’
[Mon Nov 11 01:02:28 MST 2019] Getting domain auth token for each domain
[Mon Nov 11 01:02:29 MST 2019] Getting webroot for domain=‘codymi.ms’
[Mon Nov 11 01:02:29 MST 2019] Verifying: codymi.ms

Exit code: 1

Debug Information:
OS: Ubuntu, v18.04.3 LTS
Node Version: v10.17.0
Ghost Version: 3.0.2
Ghost-CLI Version: 1.13.1
Environment: production
Command: ‘ghost setup ssl --debug’

I currently don’t have anything at codymi.ms/ghost/ and I suspect it’s because I don’t have SSL so any help would be appreciated.

if you facing a similar issue
then Check this post

Updating Acme didn’t help.

Can’t delete so I’ll just say what happened: I had done my own server configuration (installing Fail2Ban and the like) and set up all the prerequisites before going through the install article, some with different commands than what was listed. I wiped the server and tried again following the prerequisite instructions exactly and it worked great. If I had to guess what the exact error was I think I was probably using the default “localhost” MySQL hostname after I had already changed my server’s hostname.