Issue in installing Ghost on AWS cloud

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? http://18.217.96.243:2369/ghost
  • What version of Ghost are you using? Latest version
  • What configuration? Ubuntu 16 on AWS with Nginx
  • What browser? Chrome
  • What errors or information do you see in the console? Nothing
  • What steps could someone else take to reproduce the issue you’re having? Setuo ghost on Ubuntu 16 on AWS with Nginx

Could you provide more information @sophiaturka? “Latest version” isn’t helpful, what’s the version number? Could you share the steps you went through to install Ghost?

Hello David,

I’m installing Ghost v3.11.0 and I am following these steps to install Ghost on Ubuntu: https://ghost.org/docs/install/ubuntu/

Thank You

Great, thanks. Are you able to run ghost doctor? It should give a log of what is working and not working

Yes, I’m able to run “ghost doctor” and it saying the following:
:heavy_check_mark: Checking system Node.js version
:heavy_check_mark: Checking logged in user
:heavy_check_mark: Ensuring user is not logged in as ghost user
:heavy_check_mark: Checking if logged in user is directory owner
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking operating system compatibility
:heavy_check_mark: Checking for a MySQL installation

  • sudo systemctl is-active ghost_18-191-193-69
    ? Sudo Password [hidden]
    Instance is currently running
    :information_source: Validating config [skipped]
    :heavy_check_mark: Checking folder permissions
    :heavy_check_mark: Checking file permissions
    :heavy_check_mark: Checking content folder ownership
    :heavy_check_mark: Checking memory availability
    :heavy_check_mark: Checking binary dependencies

But I’m unable to access http://blog_url:2368/ghost .

You should be accessing your site with the blog URL (without port number) you’ve entered while you were installing Ghost through Ghost CLI. When you install Ghost, it configures Nginx reverse proxy to allow connections from outside (port 80, 443) to your Ghost instance (port 2368). If you still cannot access your site even without port number, make sure you’ve opened ports 80 and 443 on your EC2 instance. https://aws.amazon.com/premiumsupport/knowledge-center/connect-http-https-ec2/

Hey @minimaluminium
Thanks for your comment.
Yes, I checked in AWS inbound settings and 80, 443 & 2368 are already enabled but still throwing error when try to open http://blog_url:2368 “Site can’t be reached”.
But when I open http://blog_url it shows NGINX page displaying " Welcome to nginx!".

:wave:t3:
Can you check if your.domain.conf exists in YOUR_BLOG/system/files? Also have you reloaded Nginx?

Ok, I have created new instance on AWS and trying on it. Will get back to you after checking the same within few minutes.

@minimaluminium
I got the same issue with new instance.
No I haven’t reloaded NGINX.
please let me know how to check .domain.conf file?