Larger images all broken

If you’re looking for help, please provide information about your environment. If you delete this template and don’t provide any information, your topic will be closed.

If you aren’t running the latest version of Ghost, the first thing we will ask you to do is update to the latest version of Ghost.


  • How was Ghost installed and configured?
    Initially from a Bitnami image on AWS, but I upgraded both nodejs and ghost before posting here.

  • What Node version, database, OS & browser are you using?
    Node 14.17.1
    OS is Debian 10
    Database is MySQL
    Browser symptoms are the same on Chrome, Firefox or Edge

  • What errors or information do you see in the console?
    No errors in the console.

  • What steps could someone else take to reproduce the issue you’re having?
    I’m not sure exactly how to reproduce this. The symptoms are that any images over around 400 pixels wide do not show up on any of the published pages. They work fine in editor mode, it’s only the published pages with the broken/missing links. I suspect something is going wrong with the auto-resizing of larger images.

You can look at the “What is Bitcoin” blog post that I created to see what I mean:

By experimenting with it I’ve found that small-ish images (say less than 400px wide) seem to show up. You can see the single image that actually loads in that post above. I’ve tried other images of a similar size and they also work fine. Oddly I can also right-click on the broken image icon and “open in new tab” and the image shows up fine.

Anyone know what’s going on here?

Looks like your url is incorrectly configured - if your site uses https, your URL needs to be configured with the https URL :slight_smile:

No, the URL works just fine. Why do you say it is incorrectly configured? I’m able to load the https site both on a web browser and mobile phone. I went back and downsized all the images and they are all working now, unfortunately at a lower resolution though.

Shows your url as which is not correct

Well, be that as it may, the site loads and https is working. I’m not keen on breaking it. I think Bitnami does some custom configuration with the https / LetsEncrypt setup to get it working this way. I’ll just stick with what I have and use smaller images for now.

All I can tell you is this is 100% the wrong way to configure Ghost if you’re trying to use SSL :slight_smile: I’ve seen people on the forum have Bitnami correctly set up with no issues.

Ok, i updated config.production.json and the canary link now shows the correct https URL. But unfortunately the site now redirects to localhost in the browser when I try to load it:

The dashboard link loads fine though. It’s just when I try to hit the main public URL that the redirect happens like that.

Can you try opening the url incognito? It works for me right now :confused:

Ugh…chrome is such a PITA sometimes. Incognito works, and Firefox browser works too. Wiping out the Google Chrome cache seem to have fixed the issue.

Hey, thanks for sticking with me on this, I really appreciate the help! Gonna try uploading some larger images now…


Bingo, back in business. @vikaspotluri123 you are the best!

1 Like

I went through all of this too. Thanks for posting.

{EDIT/SOLVED} if you’re using the docker image though unraid (or maybe just docker?) then you have to make sure the https is setup in the container config not just (or only) in config.production.json file. fixed it for me.

I am experiencing the same issue. my prod json is set to https. but that link you posted to check ssl status show my site as http… have tried opening in incognito and other web browsers (IE, safari,opera etc to negate any temp files or cookies. I have posted the same images in various sizes to show that ~500px is the highest width before images break. I have no idea why this would be happening, or why ssl has anything to do with showing images above 500px?

Thanks for help in advance.