Let’s Encrypt no longer used by ghost-cli

If you’re looking for help, please provide information about your environment. If you delete this template and don’t provide any information, your topic will be closed.

If you aren’t running the latest version of Ghost, the first thing we will ask you to do is update to the latest version of Ghost.

  • What version of Ghost are you using? ghost-cli 1.17.3

And

  • How was Ghost installed and configured? As per the install guide
  • What Node version, database, OS & browser are you using? node 14.17.5, mysql 8.0.26
  • What errors or information do you see in the console? See below
  • What steps could someone else take to reproduce the issue you’re having? See below

Version 3 of acme.sh changed the default CA from Let’s Encrypt to ZeroSSL (who acquired acme.sh). Running either ghost install or ghost setup ssl displays a message:

Setting Up SSL >> Getting SSL Certificate from Let’s Encrypt…

but the output in the ghost-cli log shows:

Using CA: https://acme.zerossl.com/v2/DV90

Either ghost-cli should be updated to say it’s using ZeroSSL, or acme.sh should be reconfigured to use LE again with acme.sh --set-default-ca --server letsencrypt.