Ghost SSL Fails on CA order process

If you’re looking for help, please provide information about your environment. If you delete this template and don’t provide any information, your topic will be closed.

If you aren’t running the latest version of Ghost, the first thing we will ask you to do is update to the latest version of Ghost.

  • What’s your URL? This is the easiest way for others to help you

  • What version of Ghost are you using? If it’s not the latest, please update Ghost first before opening your topic
    ghost -v
    Ghost-CLI version: 1.17.3
    Ghost version: 4.11.0 (at /var/www/coaltocloud)

  • How was Ghost installed and configured?
    manually with ghost CLI

  • What Node version, database, OS & browser are you using?

My domain is:

My web server is (include version):
nginx version: nginx/1.14.0 (Ubuntu)
The operating system my web server runs on is (include version):
18.04.5 LTS

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

I ran this command:ghost setup ssl
? Enter your email (For SSL Certificate)

  • sudo /etc/letsencrypt/ --issue --home /etc/letsencrypt --domain --webroot /var/www/coaltocloud/system/nginx-root --reloadcmd “nginx -s reload” --accountemail EMAIL
    ? Sudo Password [hidden]
    ☱ Setting up SSL > Getting SSL Certificate from Let’s Encrypt
    :heavy_multiplication_x: Setting up SSL
    One or more errors occurred.
  1. ProcessError

Message: Command failed: /bin/sh -c sudo -S -p ‘#node-sudo-passwd#’ /etc/letsencrypt/ --issue --home /etc/letsencrypt --domain --webroot /var/www/coaltocloud/system/nginx-root --reloadcmd “nginx -s reload” --accountemail
#node-sudo-passwd#[Sat Aug 14 18:13:12 UTC 2021]
[Sat Aug 14 18:13:12 UTC 2021] Please add ‘–debug’ or ‘–log’ to check more details.
[Sat Aug 14 18:13:12 UTC 2021] See: How to debug · acmesh-official/ Wiki · GitHub

[Sat Aug 14 18:11:56 UTC 2021] Using CA:
[Sat Aug 14 18:11:56 UTC 2021] Single domain=‘’
[Sat Aug 14 18:11:56 UTC 2021] Getting domain auth token for each domain
[Sat Aug 14 18:11:58 UTC 2021] Getting webroot for domain=‘’
[Sat Aug 14 18:11:58 UTC 2021] Verifying:
[Sat Aug 14 18:11:58 UTC 2021] Processing, The CA is processing your order, please just wait. (1/30)

I had the same error when trying to set up a Ghost instance on a subdomain. HSTS was configured (which I’d forgotten about) and so the HTTP acme verification failed; I had to run the following to do a DNS verification; afterwards ghost setup ssl worked:

sudo su
/etc/letsencrypt/ --set-default-ca --server letsencrypt --issue --home /etc/letsencrypt --dns dns_cf --domain --webroot /var/www/ --reloadcmd "nginx -s reload" --accountemail
1 Like