Loading has failed. Try refreshing the browser!


I just updated my self-hosted Ghost blog to 5.69.1, which has rendered my posts inaccessible from the dashboard. Please help. None of the posts, published or draft, can be accessed. If I try to publish a new post, the blog section doesn’t let me add any text. There’s no cursor. Tried refreshing the browser multiple times, even in incognito. Nothing worked. Please help.

Version: [5.69.1]

Database: mysql8

Mail: SMTP

Yikes! Any messages in the error logs?

I see this error repeatedly:

NoPermissionError: Authorization failed
    at authorizeAdminApi (/var/www/blog/versions/5.69.1/core/server/services/auth/authorize.js:33:25)```

In your log it says “Authorization failed” quite a few times. I have had a look in the implementation of the Ghost core and that error message is generally only thrown when you try go access content with an invalid session or content API key (no surprise there, I know…)

I’d try logging out and back in, but you say that you’ve already tried it in an incognito mode – which should solve the session problem.

What about a completely different browser, just to be sure? Any luck there?

If everything else fails, I would try to connect to your database, go find the sessions table and delete the stuff that’s in there. Maybe some session data got corrupted during the update? That would, however, also log out any other users that might be logged in right now, so keep that in mind.

Edit: one more thing I just thought of – have you had a look at the network tab of your browser’s developer tools to see what networks requests are being made when you access the editor? If yes, what’s the response from the content API? Are you getting a 403 error anywhere?

@jannis & @Cathy_Sarisky Thank you so much for your help. I for the time being ran ghost update --rollback to the last major version 5.66.0 and it worked. At least for now.

1 Like

Alright, happy to hear you can work, at least :slight_smile:

I have just updated a bunch of client websites to 5.69.1 and haven’t ran into the issue myself, so that makes me curious.

Have you updated directly from 5.66.0 to 5.69.1 then?

IIRC it was directly from 5.5x

@Amit_Ashwini the logs that would be useful are the browser error logs. You can access those by right-clicking on the page and choosing “Inspect” or “Inspect Element” and then clicking on the “Console” tab.

Authorization failed errors are entirely expected when you’re logging in to the admin area or browsing the front-end when not logged in as a member. They are unrelated to the editor not loading.