Message: Systemd process manager has not been set up or is corrupted

Hello there, when I attempt to start my blog I get this error, and I haven’t had this problem before and can’t find anything online. Could someone please help me with this? I would be more then appreciative.

star@schoolfactsonline:/var/www/blog$ sudo ghost start
It looks like Ghost was installed using the root user.
You need to create a user with regular account privileges and migrate your installation to this user.
There’s a guide to fixing your setup here

Love open source? We’re hiring Node.js Engineers to work on Ghost full-time.

  • sudo systemctl is-active ghost_blog-schoolfactsonline-com
    :heavy_check_mark: Checking system Node.js version - found v16.13.0
    :heavy_check_mark: Ensuring user is not logged in as ghost user
    :heavy_check_mark: Checking if logged in user is directory owner
    :heavy_check_mark: Checking current folder permissions
  • sudo systemctl is-active ghost_blog-schoolfactsonline-com
    :heavy_check_mark: Validating config
    :heavy_check_mark: Checking folder permissions
    :heavy_check_mark: Checking file permissions
    :heavy_check_mark: Checking memory availability
    :heavy_check_mark: Checking binary dependencies
    :heavy_check_mark: Checking systemd unit file
    Warning: Ghost is running with node v14.19.3.
    Your current node version is v16.13.0.
    :heavy_check_mark: Checking systemd node version - found v14.19.3
    :heavy_multiplication_x: Starting Ghost: blog-schoolfactsonline-com
    A SystemError occurred.

Message: Systemd process manager has not been set up or is corrupted.
Help: Run ghost setup linux-user systemd and try again.

Debug Information:
OS: Ubuntu, v20.04.4 LTS
Node Version: v16.13.0
Ghost Version: 4.39.0
Ghost-CLI Version: 1.19.3
Environment: production
Command: ‘ghost start’

Try running ghost doctor to check your system for known issues.

You can always refer to Ghost-CLI - A fully loaded tool for installation and configuration for troubleshooting.
star@schoolfactsonline:/var/www/blog$

Attempting to run the command listed does nothing:

star@schoolfactsonline:/var/www/blog$ ghost setup linux-user systemd
┌──────────────────────────────────────────────────────────────────────────────────┐
│Warning: MySQL 8 will be the required database in the next major release of Ghost.│
│ Make sure your database is up to date to ensure forwards compatibility. │
└──────────────────────────────────────────────────────────────────────────────────┘

Love open source? We’re hiring Node.js Engineers to work on Ghost full-time.

Systemd service has already been set up. Skipping Systemd setup
:information_source: Setting up Systemd [skipped]

There are messages pointing to the issue…

Have you performed the last command? I suspect there are two issues at play: you used sudo when installing Ghost, and you haven’t setup MySQL correctly. BTW, use MySQL not MariaDB.

Greetings,

When I run the last command I get this error:

Systemd service has already been set up. Skipping Systemd setup
:information_source: Setting up Systemd [skipped]

If I can’t figure this out, my plan was to just reinstall ghost unless this is a simple fix. I’ve already had multiple issues updating ghost.

Greetings,

I have reinstalled ghost and got things working perfectly fine. Sorry for the hassle.

I wasn’t in a position to reinstall, I managed to fix this by manually changing the settings to something that worked:

  1. Within your ghost website folder, run ls -l to see the folder settings
  2. Run sudo chown ghost-mgr <folder-name> or sudo chown ghost <folder-name> until you are able to do the commands

Sample settings that worked for me:

-rw-rw-r--  1 ghost-mgr root       799 Jun 20 12:56 config.production.json
drwxrwxr-x 11 ghost     ghost     4096 Jun 20 03:15 content
lrwxrwxrwx  1 ghost-mgr ghost-mgr   29 Jun 20 03:19 current -> /[redacted]/versions/5.2.3
drwxr-xr-x  3 ghost-mgr root      4096 Jun 20 03:20 system
drwxrwxr-x  3 ghost-mgr ghost-mgr 4096 Jun 20 03:15 versions