Minor hiccup during update to 2.11.0


#1

Had a minor hiccup doing the update today, the context was the following:

  • ran ghost update on one of the sites, got the ghost-cli latest version warning (but the update worked without errors or warnings)
  • did the ghost-cli update (sudo npm install -g ghost-cli@latest) and it seemed to have worked ok
  • tried ghost update on the second site, got the errors below (seems like a connection problem, but was strange as it only retried once and exited and seemed to mention/refer 2.10.1 rather than 2.11.0)
  • retried ghost update (second time worked)
  • last site update worked without any warnings/errors

Log details below:

:heavy_check_mark: Checking system Node.js version
:heavy_check_mark: Ensuring user is not logged in as ghost user
:heavy_check_mark: Checking if logged in user is directory owner
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking folder permissions
:heavy_check_mark: Checking file permissions
:heavy_check_mark: Checking content folder ownership
:heavy_check_mark: Checking memory availability
:heavy_check_mark: Checking for available migrations
:heavy_check_mark: Checking for latest Ghost version
:heavy_multiplication_x: Downloading and updating Ghost to v2.10.1
A ProcessError occurred.
Message: Command failed: yarn install --no-emoji --no-progress
warning ghost@2.10.1: The engine “cli” appears to be invalid.
error https://registry.yarnpkg.com/lodash/-/lodash-4.17.11.tgz: Extracting tar content of undefined failed, the file appears to be corrupt: “ENOENT: no such file or directory, chmod ‘/home/ubuntu/.cache/yarn/v4/npm-lodash-4.17.11-b39ea6229ef607ecd89e2c8df12536891cac9b8d/node_modules/lodash/fp/functionsIn.js’”
yarn install v1.12.3
[1/5] Validating package.json…
[2/5] Resolving packages…
[3/5] Fetching packages…
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
info There appears to be trouble with your network connection. Retrying…
Exit code: 1
Debug Information:
OS: Ubuntu, v16.04
Node Version: v6.16.0
Ghost-CLI Version: 1.9.9
Environment: production
Command: ‘ghost update’


#2

@dsecareanu unfortunately the npm registry occasionally has hiccups which result in corrupted packages, it looks like you hit one of those. Retrying the upgrade was the correct solution :+1:


closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.