Multiple installs on Digital Ocean - install error

OS: Ubuntu, v18.04.4 LTS
Node Version: v12.18.0
Ghost Version: 3.29.1
Ghost-CLI Version: 1.14.1
Environment: production
Command: ‘ghost setup’

Hello there - I’m following the instructions outlined here :

to install multiple blogs on a single droplet.

I’m getting these errors on ‘ghost setup’ every time :

  1. CliError

Message: Error trying to connect to the MySQL database.
Help: You can run ghost config to re-enter the correct credentials. Alternatively you can run ghost setup again.

  1. GhostError

Message: ER_NOT_SUPPORTED_AUTH_MODE: Client does not support authentication protocol requested by server; consider upgrading MySQL client
Help: Unknown database error
Suggestion: journalctl -u ghost_thiskindofthing-is -n 50```

I’ve checked that my mysql root password is entered correctly (against the config.production.json file) and am banging my head trying to work out what I’m doing wrong.

I’m not a CLI expert by any means, so any pointers would be really appreciated!|

Are you using Ubuntu 18.04?
If so then check the Mysql authentication mode… Make sure its set to use native_password

type sudo mysql if you can login to mysql server console with the command that means your mysql auth mode is set to auth_socket mode… you need to switch it to native password mode my running below command

ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'password';
FLUSH PRIVILEGES;

It seems I was running it in mode, so I ran the command, however I’m now getting a different error…

  1. ConfigError

Error detected in the production configuration.

Message: ER_ACCESS_DENIED_ERROR: Access denied for user ‘root’@‘localhost’ (using password: YES)

Configuration Key(s): database.connection.user / database.connection.password

Current Value(s): root / password_here

Help: You can run ghost config to re-enter the correct credentials. Alternatively you can run ghost setup again.

I’m now also finding that I can’t run sudo. mysql -u root -p in order to connect to mysql anymore… Is that right?

sorry! I take it back. I did the stupidest error possible… :slight_smile:

Seems password issue did you changed the password on the command ?
if not your current password is passoword

Login to mysql with the password password & then rerun the above command with your original password & it will work

yeah that’s what I did wrong…

embarassed

Works great now, thanks so much for your help!

1 Like

You are welcome… Happy to help.
Cheers!

Hello! Tried doing the same, but on Vultr instead. Works about the same, but somehow I cannot understand how to get one domain pointing at one IP-address and another domain pointing at the second address.

The domain fake-space.com is pointing towards IP address 78.141.208.234 and on the server the folder is located on Ubuntu 16 at /var/www/ghost
The domain fakepilot.com is pointing towards IP address 185.92.221.8 and another Ghost is running on /var/www/fakepilot.com

Still, both fake-space.com and fakepilot.com are showing the /var/www/ghost folder?

OK, solved it myself. I did not need a secondary IP-address.
On the server, on /etc/nginx/enabled-sites/ there should be a .conf for each domain and -ssl.conf. I was missing a -ssl.conf for the fakepilot.com-ssl.conf…