New Ghost Install - SSL Failed

I’m installing Ghost on a new DO droplet using for server management. During the Ghost install, when asked whether to set up SSL, I get the following error.

  1. SystemError

Message: Your domain name is not pointing to the correct IP address of your server, check your DNS has propagated and run ghost setup ssl again

Visiting the website will result in a timeout.

Debug Information:
OS: Ubuntu, v18.04.4 LTS
Node Version: v12.18.1
Ghost Version: 3.21.0
Ghost-CLI Version: 1.14.1
Environment: production
Command: ‘ghost setup ssl’

Update 1: I’ve installed certbot and tried to install the SSL manually instead. I’ve ran into problems saying that my firewall is blocking access.


Hey @redchalk :wave:
Do you have your domain DNS pointing to the server with Ghost installed? This needs to be done before you an apply an SSL :blush:

Hi David,

Yes, I forgot to mention that but that’s the first thing I did after creating the droplet. I used an online domain DNS lookup to confirm too. I pinpointed the problem that it’s a firewall issue with Moss. I added rules for HTTP and HTTPS to allow all ip4 and ip6 connections (4 new entries total), restarted the server, still no go. I’m checking the server for open ports using an online website that also reports “closed”. I might have to drop Moss if I can’t figure out their firewall and there are no guides on their website to refer to.

BTW, if Moss creates a separate sudo user other than root, do I still need to create a new sudo user for Ghost or can I use the Moss sudo user for the install?


In the Moss CP, I had to add rules for HTTP & HTTPS to allow all ip4 and ip6 connections. After doing so, I did a clean Ghost install and it’s working fine. During the Ghost install, you’re asked for the blog URL, input the WWW version. The site is loading fine. Now, I need to redirect all traffic from non-www to www instead.

1 Like