New to ghost need some help


#1

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? This is the easiest way for others to debug your issue
  • What version of Ghost are you using?2.9.1
  • What configuration?
  • What browser?
  • What errors or information do you see in the console?
  • What steps could someone else take to reproduce the issue you’re having?

Hello iam new to ghost and have a question regarding the editor and trying to add prism syntax.Maybe i missed something but iam a little confused,i installed prism locally to my machine and followed these instructions


when i go into the editor to write a new post in ghost i type the 3 back quotes to try out the prism syntax highlighting but the 3 back quotes disappears and a multiline textbox shows up i can type anything with a <> inside the box and it will do syntax highlighting.My question is what is the multiline box is it markdown?What would be causing this?Thanks


#2

Ok found out the 3 backquotes are part of markdown and thats why the box is popping up.I need a way to disable markdown completely or for only when 3 backquotes are typed.I have found a work around by using html’s pre,and code tags plus the class attributes but its kind of embarrassing having to write html when prism supports much simpler syntax.


#3

When writing directly into the editor, 3 backticks are auto-converted for you. This is the markdown-like behaviour of our editor, but not markdown itself.

You can choose to break out of our default editor into pure markdown, or pure HTML, by using the markdown or HTML cards.


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.