Node configuration - DigitalOcean Droplet

Hi everyone,

I decided that had to update my Ghost installation today. When I tried to upgrade I had to update my Node version first so I ran an update on my Ubuntu server and also installed the new version of Node. However, after upgrading, I figured I accidentally updated to v20 instead of a v18 installation of Node. After this I downgraded to the latest v18 version that was recommended. Everything went super smooth.

However, after I ran the ghost upgrade command everything went well up till the build in Ghost Restart command.

After running ghost doctor I got this:

✖ Checking systemd node version - found v16.20.2
One or more errors occurred.

1) SystemError

Message: Ghost v5.75.1 is not compatible with Node v16.20.2
Help: Check the version of Node configured in /lib/systemd/system/ghost_yourdaily-tech.service and update it to a compatible version

Debug Information:
    OS: Ubuntu, v22.04.3 LTS
    Node Version: v18.12.1
    Ghost Version: 5.75.1
    Ghost-CLI Version: 1.25.3
    Environment: production
    Command: 'ghost doctor'

But when I try to look for this file on my server via FileZilla, or search though the command line, I can not seem to find this path. I am pretty sure that all I have to do is manually fix a version in this file. But I do need some help.

Sounds like there are two node versions installed right now. Any chance you’re using nvm?

Hi Jannis,

I am not using NVM as far as I know. I have never installed it.

In the end I have restored a DigitalOcean Droplet Backup. It is all working now.

1 Like