Node version mismatch

I was exploring ghost repo for my open source contribution and I tried running gscan locally and am facing node version mismatch issue.

Just wanted to check with you is this how you want the repo to be? Or I can update the dependencies to the latest version?

Error Message:

warning ../../package.json: No license field
error gscan@4.42.0: The engine "node" is incompatible with this module. Expected version "^14.18.0 || ^16.13.0 || ^18.12.1". Got "20.9.0"
error Commands cannot run with an incompatible environment.

The officially supported version of node is v18:

Since v16 support has only been dropped recently, I doubt that v20 is sufficiently tested yet.

Not official information, just my thoughts on this – essential stuff like the node version I’d leave up to the core team.

1 Like

Hi @jannis

Thanks for your reply, I think I have not framed my question properly. I will try to explain the scenario one more time
I’ve chosen to contribute to gscan as a contributor. However, upon running it locally, I noticed a version mismatch.

I seek clarity on the following points:

  1. If the core team has mandated development contributions to adhere strictly to the mentioned Node version, I’m willing to configure my system accordingly.

  2. Alternatively, if the core team permits upgrading the repository to a newer Node version, it would necessitate a change in tasks.

I hope this clarifies my query. Thank you for your assistance.

I suggest going with option 1, since the core team handles node version support and upgrades.