Podcast post not appearing on podcast page despite using the tag 'podcast' on the post?Tags

Hi Team,

So the answers given for the question I have from what i’ve read are way above my payscale lol…

So I have my home page.

I also have a podcast page.

I would like my podcast posts to appear on my podcast page only.

Right now and despite using a tag ‘podcast’ i cant even get the podcast post to appear on my podcast page using the tag ‘podcast’

little I’m looking for a hlping hand to show a step by step of how to do this as currently the answers albeit written in english, I dont understand.

If you can take th time to help I will be eternally grateful .

I very frustrated John

By default, that’s not a behavior that Ghost does. (You /might/ be using a theme that does do it – name the theme, please.)

What you probably want to do (works in any theme) is use the url /tag/podcast as your podcast page. That’ll show all the posts that have the podcast tag. (As long as it’s podcast and not #podcast. This doesn’t work with internal tags.)

thank you very much your reply. Really appreciated.

what im confused with is

url /tag/podcast

what does tag mean in your example above

For example the page url is PODCAST what part of this is the ‘Tag’ you’re referring to?

How do i get the page to show url /tag/podcast?

many thanks


Nope, I’m saying that if you go to https://whateveryoursiteis.xyz/tag/podcast , you’ll see that you already have a collection of all your posts with the podcast tag.

Thanks Cathy.

so this is the page URL PODCAST

I write the post.

I add the TAG ‘Podcast’

I update

The url stays the same EP001 - INTRODUCTION | ZERO BS ESTATE AGENCY

I want the post to appear on my podcast page.

I dont seem to have the option https://www.zerobsestateagency.com/podcast/podcast ?

Your ‘podcast’ page is here: https://www.zerobsestateagency.com/tag/podcast/
(Link for convenience: Podcast - Zero BS Estate Agency )

As you add additional posts with the tag ‘podcast’, they will also appear on that page.

You can add some introductory words and perhaps image at /ghost/#/tags - click the podcast tag and you’ll see the fields that can be customized.

thank you. So just clicked the podcast tab in menu and the link you kindly sent dissappeared : (

In other words, doesnt seem to be attached to podcast page? : (


Got it.

On the navigation page it has to look like this


thank you so much for your help

1 Like

Exactly! Happy Ghosting! Come on back whenever you need some more help!

1 Like