Problems with local installation


For some reason, I have trouble installing the latest 4.59.1 version locally.
That is to say, the installation went well, I can create an admin account but when I do ghost stop I cannot get it running again. ghost start always gives me this:

✖ Checking system Node.js version - found v18.16.0
ℹ Ensuring user is not logged in as ghost user [skipped]
ℹ Checking if logged in user is directory owner [skipped]
✔ Checking current folder permissions
✔ Validating config
✔ Checking memory availability
✔ Checking binary dependencies
One or more errors occurred.

1) SystemError

Message: The directory /home/myuser/ is not readable by other users on the system.
This can cause issues with the CLI, you must either make this directory readable by others or install node and Ghost-CLI in another location.

Debug Information:
    OS: ubuntu, v7 Horus // this is elementaryOS 7 Horus
    Node Version: v18.16.0
    Ghost Version: 5.49.1
    Ghost-CLI Version: 1.24.0
    Environment: development
    Command: 'ghost start'

EDIT: And now this - when a ghost is not running, ghost restart works, while at the same time ghost start produces the error. What’s with that??

On the same note, I don’t understand why Ghost installed locally won’t work on any Nodejs version than the one that it’s been installed with. How does one update the Nodejs on the local installation? I tried adding a newer version in package.json but with no luck.


Ghost still not support Node 18, use Node 16 instead.

Thank you @cuongtran for your time and effort. It appears that Ghost does support Nodejs v18.x, you can check it here

Also, I’m sorry not to specify it before, the same happens with Nodejs versions 16.13.1 and 16.15.1

Try command

sudo chown <user>:<user> /home/myuser/

Replace <user> is your user

All is fine with my home dir, that’s not the issue.