Redirects not working

Is anyone having issues with redirects? I noticed that my redirects aren’t working. I did not make any changes to the redirects file, and they have been working fine up until today. I also have a valid file uploaded on the redirects tab in Settings.

I’m not aware of a general issue, no. If you’d like help debugging, provide a specific URL that’s not redirecting and your redirects.yml.

Also, did you change anything recently, like upgrading Ghost?

Also please provide your Ghost version.

Reviewing your Nginx and Ghost logs may also help.

Hi @markstos Thank you so much for your response.

I had set-up many redirects, which were working fine until two days ago… For instance, this page was set up to redirect to this page. Similarly, this page was set up to redirect to this page. I did not change anything from my end and have a valid yaml redirects file in settings.

I’m on the Ghost (Pro) Starter plan and did not change anything recently.

My Ghost version is 5.60.0+moya

Please advice :pray:t2:

Did you upload a new redirects.yaml?

When I found the redirects were not working, I downloaded the file to see if anything had changed. There were no changes.

And so I tried to Google and see what could be done, and some forums stated that re-uploading the file may work. So I tried that. But it did not fix anything :(

Post it? Maybe we can spot what you’re missing.

1 Like

Hi @markstos and @Cathy_Sarisky here is the redirects file

The file appears to be missing indentation.

All the lines after 301 or 302 should be indented a couple of spaces.

But the way you describe how it “just happened” makes it sound a like a problem with the Ghost(Pro) hosting. Since you are customer there, you can contact for commercial support.

1 Like

I mean, last update here was on September 1 from you – and you got a reply.

Did you reach out to Ghost support?

Either way, feel free to share your current redirects file – I assume you have changed something, since @markstos pointed out that the indentations are missing?