Remove all author and tag pages from sitemap

Hi, I have noindex on my tag and author pages, however, if you have noindex pages that are on your site map, google search console shows them as errors. Is there a way to remove tag pages and author pages from the automatically generated sitemap? As most don’t have enough content to be in any way beneficial for SEO.

I have looked on the forum and in 2018 there was a response to a similar post saying that this functionality was being built at the time and to track it here. However, that appears to just exclude tag & author pages with no posts, not those with very few posts.

So is there any way to completely get rid of tag and author pages from my sitemap?

Any help would be hugely appreciated

1 Like

Ghost’s sitemap is automatically generated. If you want a custom one, you’d need to build it using routes and templates, using the same methodology as this tutorial for building custom RSS feeds:

1 Like

Hi Hana, thank you for the link. If I build a custom sitemap, how should I disable the Ghost’s generated one?


same problem. How should i disabled it from sitemap ? Did you find any method or trick ? please let me know.

Sadly not @Keval_Rathod - and google still find and crawl those sitemaps even if you don’t submit them in search console.

@Hannah is it possible?

@Hannah is it possible?

1 Like

@Hannah up. How to disable Ghost-generated sitemap? @Sarah maybe?

I also have the same issue. I need to remove author pages from sitemap, but there is no option to achieve that. I used nofollow, noindex in the header to let Google know. But GSC complaints with errors :(

Crazy isn’t it @Madusanka - when you use a site map plugin for any jamstack language like react or vue, you can choose which pages to include and which not to include, along with using wildcards like all pages with …/pages/*

1 Like

So crazy. We face a lot of difficulties implementing SEO on the websites :cold_sweat:

I opened an issue. Let’s see how the team respond to it. A way to remove tag and author pages from sitemap · Issue #13776 · TryGhost/Ghost · GitHub

Nice, please let me know if they do respond @Madusanka. Sadly, I’m sceptical that they willl - this problem has been here in the forum for a long time!

Got an update saying they don’t track feature requests on GitHub. Instead asked to create idea in the forum. Created a one and posting here for upvoting (@TomJP FYI)

1 Like

I found a workaround to sort this out but you need to edit the sitemap generation files in the following path.

The steps

  1. Inside your ghost installation visit /current/core/frontend/services/sitemap/ path
  2. Edit manager.js and find createIndexGenerator() method
  3. Remove authors and tags from the types
    The commands
cd /current/core/frontend/services/sitemap/
vi manager.js or nano manager.js

The createIndexGenerator() method should look like,

createIndexGenerator() {
        return new IndexMapGenerator({
            types: {
                pages: this.pages,
                posts: this.posts

Hope this helps

1 Like