Routing issue: RSS working local, but not on Ghost-server

Hi everyone…!

Our v1 news website is in development. Nearing completion, it also needs to offer an RSS-feed.
Thanks to the Custom RSS + Ghost tutorial, it is working in my local version of Ghost, see screen shot below. :tada:
BTW, I dont know if the rss.hbs file is supposed to style the raw html shown. If it is, that rss.hbs is not working…

However, going live to our domain hosted on PRO , the RSS page is giving a problem. After uploading my custom theme and the routes.yaml, the site is running perfectly as usual, but now returns a 404 error page on the /rss URL. See routes.yaml file below.

Can someone tell me why and how to fix this…? :pray:

  /: home
    template: rss
    content_type: text/xml

    permalink: /{primary_tag}/{day}/{month}/{year}/{slug}/
    template: index
  tag: /{slug}/
  author: /author/{slug}/

Hi there! If you’re having any issue with a Ghost(Pro) site, please drop us an email on and we’ll be more than happy to give you a hand directly :slight_smile:


:information_source: Solution from the Ghost Support team:

‘When a site is in private site mode, the RSS feed wouldn’t be accessible. However, once you take the site out of private site mode from within the Settings > General area, it should be visible. 🙂 You can test this by toggling off private site mode, checking the RSS feed, then you could re-enable private site mode after testing, if you’d like to keep the site private still.’

1 Like

Thanks for sharing! :)

1 Like