Server hangs when executing "ghost install"

Good Afternoon.

I am currently running an Ubuntu 18.04.2 Server under ESXi. The server is a fresh install and has no other applications loaded on it. I attempted to install Ghost using the directions provided in “https://docs.ghost.org/install/ubuntu/” though I have substituted MariaDB for MYSQL which I have been told should drop in fine and there are other guides online recommending it over MySQL.

When executing “ghost install” the installation proceeds to "Downloading and installing Ghost v2.25.6 > Installing dependencies > [5/5] Building fresh packages…

Once at this step the server will hang requiring a full reboot to restore functionality. Near as I can tell no error logs are produced.

I attempted to reload the OS in the hopes it was simply something corrupted but the same symptoms occurred.

Can anyone provide any guidance in troubleshooting?

Best regards,
~Vince N.

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? This is the easiest way for others to debug your issue: N/A - I am installing in a local development environment.

  • What version of Ghost are you using?: 2.25.6

  • What configuration? : Non-Local Standalone

  • What browser? : N/A - Issue is occurring installing on the server

  • What errors or information do you see in the console?: None. When executing “ghost install” the installation proceeds to "Downloading and installing Ghost v2.25.6 > Installing dependancies > [5/5] Building fresh packages…

  • What steps could someone else take to reproduce the issue you’re having? Execute Ghost install

How long are you waiting for the “Building fresh packages…” step to complete?

Before typing this up I got frustrated and just left it after the server hung on the last attempt. I came back about a day later and the server was still hung so I rebooted it. So… about a day?

I just attempted to install from a fresh state again, this time following the directions precisely the same using MySQL instead of MariaDB just to be sure that wasn’t a cause.

Same error. Attaching screenshot of what putty shows in case it’s helpful.
Opening to the server console window in ESXi is showing the server in a hung state again.

Which cli version are you using ?

I’m not sure. It’s downloaded from the server as part of the official documentation I linked above so I assume it’s the most recent version.

Kevin I am not sure if I replied to you correctly earlier. Was wondering if you saw my responses?