Setup SSL for your www domain

Hello There,

I am trying to setup an SSL certificate for my domain.

This is my domain name:

After I entered ghost setup nginx ssl into the command line terminal, it gives me the following message:

  1. ProcessError

Message: EACCES: permission denied, open ‘/tmp/thevaluehive-com/’

Exit code: EACCES

I have been told that what this means is that whenever you get an eacces error you have to give your user permissions to that folder. I have tried this using the following command:

sudo chown user:user pathtofolder, but then get a message saying cannot access that folder.

I’m really desperate for help in trying to resolve this error.

Here is my terminal environment:
OS: Ubuntu, v18.04.4 LTS
Node Version: v12.18.0
Ghost Version: 3.41.7
Ghost-CLI Version: 1.15.3
Environment: production
Command: ‘ghost setup nginx ssl’

Not sure how helpful this is, but if you are considering doing it yourself then have put what I have found are some helpful links here including how I manage SSL certificates How to organise and get a Bitnami Ghost instance started on Amazon EC2

Hi Matt and thanks for the reply and help,

I don’t bitnami applies in my case, but i feel i have messed up my permissions when configuring ghost.

Here goes my afternoon…

1 Like

Did you try sudo chown user:user /tmp/thevaluehive-com/ , replacing user:user with what you named your user, eg user2:user2 or admin:admin? this worked to resolve the nginx issue for me. I tried the path to the .conf file first, but an ls when I was in my equivalent of the tmp/thevaluehive-com folder showed that the file did not exist. Maybe that’s why it couldn’t be accessed?