Ghost not showing Website after setup

If you’re looking for help, please provide information about your environment. If you delete this template and don’t provide any information, your topic will be closed.

If you aren’t running the latest version of Ghost, the first thing we will ask you to do is update to the latest version of Ghost.

  • What’s your URL? This is the easiest way for others to help you
  • What version of Ghost are you using? If it’s not the latest, please update Ghost first before opening your topic


  • How was Ghost installed and configured?
  • What Node version, database, OS & browser are you using?
  • What errors or information do you see in the console?
  • What steps could someone else take to reproduce the issue you’re having?

My url is
I use node version 12.x
Ghost is not showing any errors at all
To reproduce the error basically visit

I installed the latest version of ghost and installed it after some trial and error
When it comes to starting,
I did every step and had no problems but when I try to open it in my browser it redirects me to nginx or just completely block off the connection when using :2368 at the end

I hope this is enough info and I’m happy to provide more

What are the permissions of the folder where you have installed ghost? Usually Nginx shows this error when the folder permissions do not allow Nginx to read/write the files.

As per our installation, we have all but one folders recursively owned by our user and group. the content folder is owned by ghost user and group.

Additionally, do ensure/share your nginx files at /etc/nginx/sites-available. It must be linked symbolically in /etc/nginx/sites-enabled/. In particular there should be two files by the name of and

Do share any specific tutorial or article you might be following along.


The permissions are set to 775 as ghost demanded in the tutorial
I followed the tutorial for ubuntu
There is a conf file for sites available for my website too
Update: my server now refuses connection after starting ghost


I can see your website now.

However, there is no SSL which the latest ghost-cli installs and renews automatically. Are you still facing some issue?



I am not facing any issues - it works quite will but I am using apache instead of nginx
I can’t auto set it up :slight_smile: