Site Design option won't show up as preview

Tested on Chrome, Safari, and Firefox. A preview of the website design doesn’t show up on the dashboard. I’m on 4.27.

The most common cause for issues with embeds in the admin interface is incorrect url config. Can you confirm if your url from ghost config get url starts with http or https?

I’m experiencing the same issue on HTTPS using an AWS Bitnami installation, fresh install with v.4.24.0; still experiencing upgrade issues in trying to upgrade to v 4.30.1 and have an open ticket with their platform about this at Cannot upgrade Ghost on AWS after base install - Ghost - Bitnami Community

I cannot see the site design preview and am also using the Let’s Encrypt SSL certificate that was issued using Bitnami’s SSL procedures.

@vikaspotluri123 – when I run this command in the AWS terminal it is showing as regular HTTP. Not HTTPS. Do you know how I can modify this setting to be the HTTPS? I have a Let’s Encrypt SSL certificate installed already.

@vikaspotluri123 – I just ran the command:
sudo ghost config url https://{mydomain.com}

Now I have an even bigger problem… Ghost wouldn’t restart, so I stopped the AWS instance and restarted it. It now shows in SSH that HTTPS is enabled for my domain but it’s now redirecting to https://127.0.0.1:2368/ when I visit my root HTTPS URL, so it’s some sort of weird redirect going on. How do I fix this @Kevin ? It’s using Bitnami via AWS for the Ghost install. Now I can’t publicly access Ghost through my web browser to check and see if the preview is working because my whole website is now down.

When I use the AWS console to perform this command, it displays as standard HTTP. This isn’t HTTPS. Do you have any suggestions on how I can change this setting to HTTPS? I’ve already had a Let’s Encrypt SSL certificate configured.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.