SSL Setup not working


#1

I am using ghost v2.7.1
I am having trouble to install SSL certificate via ghost CLI. Every time I run ‘ghost setup ssl’ I get the following error after providing my email :

:heavy_multiplication_x: Setting up SSL
A ProcessError occurred.

Message: Command failed: /bin/sh -c sudo -S -p ‘#node-sudo-passwd#’ /etc/letsencrypt/acme.sh --issue --home /etc/letsencrypt --domain XXX.XXX.XXX–webroot /var/www/romoni-blog/system/nginx-root --reloadcmd “nginx -s reload” --accountemail XXX.XXX.XXX@gmail.com
[Mon Dec 17 09:05:10 UTC 2018] new-authz error: {“type”:“urn:acme:error:rateLimited”,“detail”:“Error creating new authz :: too many failed authorizations recently: see https://letsencrypt.org/docs/rate-limits/","status”: 429}
[Mon Dec 17 09:05:10 UTC 2018] Please add ‘–debug’ or ‘–log’ to check more details.
[Mon Dec 17 09:05:10 UTC 2018] See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh

Exit code: 1

Debug Information:
OS: Ubuntu, v16.04
Node Version: v8.12.0
Ghost-CLI Version: 1.9.8
Environment: production
Command: ‘ghost setup ssl’

Additional log info available in: /home/romoni_deployer/.ghost/logs/ghost-cli-debug-2018-12-17T09_05_10_247Z.log

Try running ghost doctor to check your system for known issues.

I also tried manually installing SSL from CERTBOT, but they said "An unexpected error occurred:
The request message was malformed :: Error creating new order

Now what to do? I had the same problem installing ghost into my staging server, but 3 days later it worked & got installed perfectly!


#2

It looks like you set up SSL too many times in the past week or so. LetsEncrypt limits the number of times you can request a new certificate in a given time frame.


#3

So, now I have nothing to do but wait?


#4

Based on the logs you posted it seems so


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.