SSL's not working under local host

Ghost version: 4.12.1

I installed Ghost to host is locally, so I just followed the documentation. I’m on Fedora 34, and I use Mozilla Firefox. So I follow the localhost. I’m on a free plan. I tried running the command ghost setup ssl, and it keeps skipping the SSL step:
Found a development config but not a production config, running in development mode instead
Nginx config file does not exist, skipping SSL setup
:information_source: Setting up SSL [skipped]"
I already did sudo dnf install nginx, but this keeps coming. And obviously, without SSL, nobody can visit my websit. Help would be much appeciated.


Since you are running Ghost locally, only you can access it.

Even if you had SSL, nobody could access your local instance of Ghost, except yourself.

If you wish other people to visit your website online, you need cloud hosting. See the three options that appear below local hosting (i.e. Ghost(Pro), DigitalOcean and Linode):

1 Like