Staff new sign ups email notifications has a wrong from email address

Fill out the following bug report template with as much detail as possible!

Are you sure this is a bug? If you just need help, post in the developer help category. If it’s a feature request, head to the ideas category.

Issue Summary

  • Explain roughly what’s wrong: the new sign up notification from email address is but I have already set up all from email address as another address. Tested on comments notification and it works well but just new sign up is sending from the wrong address. It directly caused the email went to the spam folder
  • What did you expect to happen?
    The new sign up notification email should have a from address at least same as the newsletter one or the one I set in the config.

Steps to Reproduce

  1. go to Settings → Staff → click into the owner → turn on new sign ups notification
  2. a new user sign up, and the notification email will go into the spam, the email address is

Setup information

Ghost Version

Node.js Version

How did you install Ghost?
production on ubuntu

Provide details of your host & operating system
Ubuntu 22.04

Database type

Browser & OS version
edge latest

Relevant log / error output
Copy and paste any relevant log output. Use backticks to format this into code.

I see you submitted the exact same request for help as a Github issue. This sounds more like a support request. Please delete the issue there so people aren’t spending duplicate efforts to help resolve your issue.

sorry about that, closed

Could you please let me know whethere there are any updates?

Please share your config.production.json file, anonymizing any parts you need to. Thanks.

I am actually using docker but the config are similar:

database__client: mysql
database__connection__host: db
database__connection__user: root
database__connection__password: hidden
database__connection__database: ghost
mail__transport: SMTP
mail__options__service: Gmail
mail__options__port: 465
mail__options__secure: true
mail__options__auth__user: hidden
mail__options__auth__pass: hidden
mail__from:  hidden

And every time when a new member sign up I will receive emails from ghost@myblogdomain instead of the email address I set here in the smtp from address.

All other email came from ghost are having correct address

Have you checked your settings in Gmail to make sure you are allowed to use the email as the From address there?

For sure yes, I am using Google Workspace and I am the admin, I am using it all over my self-hosted services. This is 98% a ghost built in problem I am assuming. The from address actually is the default email I used to log in to the Google. So it will for sure allow

I’m just noting someone else is reporting what appears to the same issue but with 5.60.0:

Yeah correct, I think we are having the same issue now. And besides this is not working for the latest version I just tested

On Github I’ve reported more work to reproduce and isolate this bug:

Agreed, 100%

@John & @Hannah Please help getting this squared away. I love Ghost but these email envelope issues are no fun.

Not sure if this is the same thing, however, I’ll jump in here.

The Owner has nothing to do with sign-up/sign-in (email) notifications.

The below screenshot shows, and I have confirmed within my Ghost(Pro) account, that this is where the from address comes from. Personally, this isn’t great wording nor is it great from a solution perspective.

How to solve. I’d recommend having another email field within this area that specifies the notifications email address - support is not a notification address, especially with a high volume website.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.