Subscribe feature not working (resolved)

Hi all,

I upgraded to Ghost 3 a while ago and subscribers broke. I’ve tried figuring it out, and I’m sure it’s to do with routes.yaml, but I don’t know where the relevant documentation is.

I’m on fairly stock Casper with some aesthetic mods. It’s on https://hooshmand.net. Try subscribing on the front page - it goes nowhere, and I don’t receive it.

I know “subscribers” became “members” and that changed things, but just curious to know what I need to change.

Thanks in advance!

Current routes.yaml:

routes:
  /motorcycles/rss/:
    template: motorcycles
    content_type: text/xml
  /signup/: members/signup
  /signin/: members/signin
  /account/: members/account


collections:
  /:
    permalink: /{slug}/
    template:
      - index

taxonomies:
  tag: /tag/{slug}/
  author: /author/{slug}/

Hey @dana,

Have you made modifications to your routes file? Looks like you’ve copied the routes shown in the Lyra repo. Everything you should do is shown here on this FAQ page where we show how to upgrade your Subscribers code to Members:

1 Like

Oh thank you so much! I didn’t find that. Exactly what I was looking for.

Yes, I did randomly copy in the routes from the Lyra theme to see if that’d solve it… sprung!

1 Like

OK, I realise I had done all that correctly.

But members.js is missing from my installation. Maybe it didn’t make it through the various upgrades (which I just did, again, to 3.7).

Not sure why. I’ll look through the repository and see if adding it in the right place helps.

Fixed it.

I realised members.js was being sought from /public. A while ago I had created a public folder, and had set up redirects in my nginx.

I commented those out, restarted ghost, and the subscribe feature now works. Hooray!

Solution in nutshell: Make sure there’s no path for /public in the nginx/apache config, as Ghost uses that in some other way.

(Please let me know if I’ve been too glib in that summary)

1 Like

Hi, @dana
Did a fresh install with 3.16.1 with casper, updated routes.yaml as per above and restarted the ghost. problem didnt resolve. still receive please enter valid email address or it hungs with subscribe icon rotating.

Could you elaborate with your nginx/apache config file…

My nginx config is close to standard. Why do you think it’s your nginx?

I only use ghost as a backend these days.

Hi Dana,
You have mention about /public & member.js in your nginx , hence asked clarity that have any role to fix this need. But later, i realized nginx has no role for mail config issues. Thank you for responding …

At the end i fixed the mail config issues only by having account in mailgun and configured.
Is there a possible to configure non mailgun accounts in config.production.json file … ?