Subscribe functionality from Casper theme not consistently working: "Please enter a valid email address!"

Today I made public my implementation of Casper’s subscribe functionality (functionality that I linked to in a recent thread). While everything worked fine during my testing and at the initial stages of its public launch, I soon started getting emails from people saying that they were getting the “Please enter a valid email address!” message even though they were most certainly entering vaild email addresses.

I tested things again with my personal email address, and it worked perfectly fine for me. When I tested with the email addresses of my readers of which apparently hadn’t worked, lo and behold, they didn’t work. I tried mine again and things still worked fine.

An hour or so later I went back again and tried my same personal email address that had consistently worked, and this time it didn’t work. I kept trying several others (with different domains) and now nothing would work at all.

Towards the end of the day I noticed that somebody was somehow able to subscribe, their email address being a account. I tested my account and it worked as well, although attempting to use any of the previously failed email addresses would work.

I’d like to debug this, so what I’m wondering is: what exactly is determining that these valid email address supposedly aren’t? Is it being determined by Ghost or is this something to do with the Mailgun connection? And if it’s something to do with Mailgun (it’s deeming the domains of these email addresses as spam/untrustworthy?) would it be related to the data I’ve inputted into my config.production.json file or the data I’ve inputted into the Members dashboard?

Thanks for any help!

1 Like

Looks like someone had a very similar issue here and solved it by ensuring their mail configuration is setup correctly:

Hi @DavidDarnes, where can I find instructions for the AWS SES/SMTP setup? I’m having the same issue over here

I’ve been meaning to put together a write-up about this, but essentially I had to contact Mailgun’s customer support and open a ticket. Their solution was to upgrade me from a poor-quality, poorly-rated shared IP to a better shared IP. Until this point I’d been wracking my brains for several days trying to figure out why things weren’t working.

Not sure if this would be relevant at all to your situation with AWS.


Wow what a pain. Ok I think I’ll go ahead and do the same. You mind sharing what you sent in the ticket so I know what to say? :sweat_smile:

It was all specific to my situation. I grabbed error messages from the logs and relayed those to them.

I’m guessing you’ve also properly set things up with your config.production.json file, right? I’d errantly thought I’d configured it a long time ago, but actually hadn’t.

1 Like

I’ll have to check that

Here, this is what I mean:

1 Like

I’m on Lyra, not Casper.

I’ve been working on a local installation all day (on the template not on the core). I always did the tests with my @gmail email. Now, after several hours of work, it suddenly no longer works.

I’m having the “Please enter a valid email address!” Error.

It still works for other types of emails, such as

What happened suddenly?

Restarting ghost solved problem.

1 Like