Successful Installation leads to nginx default page

Hey everyone, been attempting to install ghost on a vps for quite a while, every time I go through he ubuntu instructions, the setup completes successfully with no errors. But when i visit the IP or the domain, I get the NGINX default welcome page. I followed the installation to the letter, and have ghost in var/www/ghost

Installed version 3. on ubuntu bionic

domain is
ip is

dns managed via cloudflare, and records are set up properly including the resolution of www.

This cant be an uncommon experience, I get the same problem having tried to install it on three different servers over the past year, I try to get ghost running, fail and never find a solution, and give up for a bit before I try again.

Hey @Aeternum :wave:

It looks like you might have you CF SSL settings is set to flexible, can you change it to full or full (strict)? You’re currently running into an infinite redirect loop :grimacing:

Everything seems to be working from curl, which is why I think there’s something wrong with CF :smile:

> curl -i -H "host:" -k
HTTP/1.1 200 OK
Server: nginx/1.14.0 (Ubuntu)
Date: Sun, 27 Oct 2019 17:17:27 GMT
Content-Type: application/json; charset=utf-8
Content-Length: 72
Connection: keep-alive
X-Powered-By: Express
Cache-Control: no-cache, private, no-store, must-revalidate, max-stale=0, post-check=0, pre-check=0
ETag: W/"48-TIm9c+Wb/CmEnQIrjmSf3jJN+gQ"
Vary: Accept-Encoding
Strict-Transport-Security: max-age=63072000; includeSubDomains; preload
X-Frame-Options: SAMEORIGIN
X-Content-Type-Options: nosniff

1 Like

Thanks a ton, that fixed it.