'welcome to nginx' default webpage....how do I fix this?


#1

I have a digitalocean account and Im trying to install ghost.

domain http://dittmaraz.life.
admin http://dittmaraz.life/ghost/

How do I tell nginx to serve the ghost installation instead of that default ‘welcome to nginx’ page?

config.production.json
{
“url”: “http://dittmaraz.life”,
“server”: {
“port”: 2369,
“host”: “127.0.0.1”
},
“database”: {
“client”: “mysql”,
“connection”: {
“host”: “localhost”,
“user”: “ghost-841”,
“password”: “eHx5S)QK41(&@0o-/^8H”,
“database”: “ghost_prod”
}
},
“mail”: {
“transport”: “Direct”
},
“logging”: {
“transports”: [
“file”,
“stdout”
]
},
“process”: “systemd”,
“paths”: {
“contentPath”: “/var/www/ghost/content”
},
“bootstrap-socket”: {
“port”: 8000,
“host”: “localhost”
}
}


#2

Need to see the nginx config as well in order to be able to help. Overall, it should point to /var/www/ghost/ (where you ran the ghost install). If you didn’t use the one click install from DO maybe you should try that.

Also, please do not post your user and password on a public forum (not ok from a security point of view).


#3

from nginx.conf

user www-data;
worker_processes auto;
pid /run/nginx.pid;

events {
        worker_connections 768;
        # multi_accept on;
}

http {

        ##
        # Basic Settings
        ##

        sendfile on;
        tcp_nopush on;
        tcp_nodelay on;
        keepalive_timeout 65;
        types_hash_max_size 2048;
        # server_tokens off;

        # server_names_hash_bucket_size 64;
        # server_name_in_redirect off;

        include /etc/nginx/mime.types;
        default_type application/octet-stream;

        ##
        # SSL Settings
        ##

        ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
        ssl_prefer_server_ciphers on;

        ##
        # Logging Settings
        ##

        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;

        ##
        # Gzip Settings
        ##

        gzip on;
        gzip_disable "msie6";

       gzip on;
        gzip_disable "msie6";

        # gzip_vary on;
        # gzip_proxied any;
        # gzip_comp_level 6;
        # gzip_buffers 16 8k;
        # gzip_http_version 1.1;
        # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

        ##
        # Virtual Host Configs
        ##

        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;
}


#mail {
#       # See sample authentication script at:
#       # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
#       # auth_http localhost/auth.php;
#       # pop3_capabilities "TOP" "USER";
#       # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
#       server {
#               listen     localhost:110;
#               protocol   pop3;
#       }
#
#
#}

#4

The host nginx file where you define the root folder. The nginx.conf file appears ok (just scanned it though).


#5

I would recommend to format your config properly. I makes it hard to help you at the moment.

Per example:

{
    "url": "http://localhost:2368",
    "database": {
        "client": "sqlite3",
        "connection": {
            "filename": "content/data/ghost-dev.db"
        },
        "debug": false
    },
    "auth": {
        "type": "password"
    },
    "paths": {
        "contentPath": "content/"
    },
    "privacy": {
        "useRpcPing": false,
        "useUpdateCheck": true
    },
    "useMinFiles": false,
    "printErrorStack": true,
    "caching": {
        "theme": {
            "maxAge": 0
        },
        "admin": {
            "maxAge": 0
        }
    }
}

#6

I have a blog post about setting up a Ghost blog with Docker and Docker Compose using Nginx on a Digital Ocean droplet here:


#7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.