Themes that are compatible with ghost 1 and 2?

Can anyone advise any places I can get a free ghost 1 and 2 compatible theme? Is there something that will work in both versions?

Also, can you tell me if there is a default ghost theme that works in all versions?

I am planning on which themes to leave if any when I try migrating again from ghost 1 to 2. I am going to buy a good paid theme for ghost 2 if I ever get there.

Is it safest just to delete all the themes before performing the upgrade? Because last time I think the paid theme I bought which was in Ghost 0 is what caused the problems when I went from 1 to 2.

If I have problems migrating this time I might just ask them to do a clean install of ghost 2.

Final question. How easy is it to design your own themes? I understand ghost is written in java?

Hi @john10001 :slight_smile: Will start from the end.

I understand ghost is written in java?

Nope, Ghost server is written completely in JavaScript using Node. Admin-Client is also JavaScript - Ember application and the frontend is up for the user to decide - can be integrated using Ghost’s Content API or using Ghost Themes (based on Handlebars)

How easy is it to design your own themes?

There’s a whole bunch of resources and tutorials about this topic at Ghost’s docs site

Is it safest just to delete all the themes before performing the upgrade?

Before performing an upgrade from Ghost 1.x to 2.x you can check you theme agains compatibility tool called gscan here.

Also, can you tell me if there is a default ghost theme that works in all versions?

The default Casper theme is always kept up to date with the latest version of Ghost.

Can anyone advise any places I can get a free ghost 1 and 2 compatible theme? Is there something that will work in both versions?

There’s a bunch of themes at https://marketplace.ghost.org/ , you would need to check each one specifically for Ghost 2.0 compatibility (best to do it with above mentioned gscan tool). But, from what I’ve checked all of the free themes and most popular paid themes all support Ghost 2.0 out of the box!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.