Transactional Mail with Porkbun


I have been trying to setup transactional mail (what a pain). I have a domain with email hosting through It is an .xyz domain. I am running into the issue where I can’t send a simple invite email.


Self-Hosted Ghost Details

Tech Specs

  • Ubuntu 20.04 Focal Fossa LTS
  • Ghost-CLI version: 1.18.1
  • Ghost version: 4.35.0


The reason I have secure set to false is because Porkbun generates SSL on your behalf. Though, it takes a couple of days to became active.

Not really sure what type in the auth key is used for. I can guess but write it out for me. What is type and what could it’s values be?

"mail": {
    "transport": "SMTP",
    "options": {
      "host": "",
      "port": "586",
      "secure": "false",
      "auth": {
        "type": "LOGIN",
        "user": "",
        "pass": "example"


Is there anyway to get a more detailed log? I am unsure if it is my credentials or if nodemailer doesn’t play well with Porkbun. Nevertheless, I really can’t hone in on what the issue is. I don’t have logging configured on my json file, so it is using the default values.

{"name":"Log","hostname":"","pid":2998,"level":40,"msg":"Error sending email: Failed to send email. Reason: Connection timeout. Please check your email settings and resend the invitation.","time":"2022-02-12T05:26:17.344Z","v":0}

Porkbun Details

You can set up your own email hosting with them which provides you the following:

  • 10 GB of Storage
  • Secure IMAP and POP
  • Send and Receive Email
  • Webmail
  • Email Forwarding

The email hosting details that are provided. I am unsure on which to choice port 587 or 465.

Email Client Configuration Settings

Use this information when setting up your email in Gmail, Outlook, your phone and any other email client.

Service Hostname Port Security
SMTP 465 Implicit TLS


I am at a dead end with this. I have no clue what to do differently to get it to work beside waiting on Porkbun to complete the SSL process. If anyone has suggestions or has worked with Porkbun before please help.

Follow up

I would like to mention that Porkbun created the SSL certificate. Also I inputed "port": "586", in my original post. This was wrong and I corrected it with the proper values.

With these two things in mind. I still can’t get transactional email to work.