Twitter Card not showing image in tweets or in validator

I am trying to use a twitter card on twitter, but the image is not showing. A specific example is here. I have specified a 1200x675 pixel image as the image I want to have loaded in twitter. This is closely in line with an image that another user successfully used here.

I have used the twitter card validator with different sizes and aspect ratios of images and have been unable to get a twitter card image to populate. In the validator logs I see:

INFO:  Page fetched successfully
INFO:  27 metatags were found
INFO:  twitter:card = summary_large_image tag found
INFO:  Card loaded successfully

Is there anything I am missing? I have read several forum posts where users have had twitter card image issues, (like this one) and have tried to replicate their solutions by changing image sizes and resolutions, but have had no luck…

  • What’s your URL?
  • What version of Ghost are you using? 4.21.0 (I apologize for not having the most recent version of Ghost. I’ll update tomorrow morning outside of high-traffic hours).


  • How was Ghost installed and configured?
    I installed Ghost via Docker.
  • What Node version, database, OS & browser are you using?
    Node is version 14.18.0, database is mysql, OS is ubuntu, browser is chrome.
  • What errors or information do you see in the console?
    The issue is with twitter cards and image loading.
  • What steps could someone else take to reproduce the issue you’re having?
    None that I know of.

I updated to version 4.22.0 this morning and have the same problem. I checked my console logs and no errors are shown. When I try the twitter card validator my logs show successful GET requests for the blog post itself, but no GET requests for the image I have included within Ghost in my Twitter Card options for that post, however.


Perhaps unrelated, but your specific example page’s source contains links with href starting with ”Https:” (note capital H) instead of ”https:”. Just wondering, if that might have something to do with your problem.


1 Like

Thanks Matti, that is a good idea. I’ll change that tomorrow morning to see if that is having any impact. I wouldn’t expect it to, but regardless it will be good to change. I’ll let you know if it changes anything.

Wow, that was such an irritatingly simple solution! Thanks so much for the recommendation, I would never have thought that was the issue!

1 Like

I am glad to hear! And can see it on Twitter as well. Often tiny details matter…

1 Like