Ubuntu wsl problem with instalation

Hi, I have WSL , ubuntu and now i have problem on image…can you help me ?

Looks like you’re trying to install Ghost as the user petr. That means petr needs to own /var/www/avira

1 Like

Hi, how it repair, i tryid something but not working…can you help me pls ?

I tried this… ```
sudo chown -R petr:petr /var/www/avira
sudo chmod -R 775 /var/www/avira

but not working.

I gave rightd to var/www/avira/content and i get this error

You can’t run ghost install or ghost start as root. You’ve got to run it as a user. Make sure the database user and password in your config.production.json actually has permissions and the password (database password, not shell password) is correct.

I it run as petr user no root…

No sudo either. That’s why it’s saying don’t run as root.

I created new user ai did everything here…

And not working…
again screen…

Content folder has now rights but here is another one error

That’s another permissions error, possibly the result of trying to start ghost with sudo earlier. Correct the error on the directory & file listed.

now i have this problem

Message: Ghost was able to start, but errored during boot with: Access denied for user ‘ghost’@‘localhost’ (using password: YES)
Help: Unknown database error

:heavy_check_mark: Checking system Node.js version - found v16.16.0
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking memory availability
:heavy_check_mark: Checking free space
:heavy_check_mark: Checking for latest Ghost version
:heavy_check_mark: Setting up install directory
:heavy_check_mark: Downloading and installing Ghost v5.59.2
:heavy_check_mark: Finishing install process
? Enter your blog URL: http://localhost:2368
? Enter your MySQL hostname: localhost
? Enter your MySQL username: ghost
? Enter your MySQL password: [hidden]
? Enter your Ghost database name: ghost_prod
:heavy_check_mark: Configuring Ghost
:heavy_check_mark: Setting up instance

  • sudo chown -R ghost:ghost /var/www/ghost/content
    :heavy_check_mark: Setting up “ghost” system user
    :information_source: Setting up “ghost” mysql user [skipped]
    Your url contains a port. Skipping Nginx setup.
    :information_source: Setting up Nginx [skipped]
    Nginx setup task was skipped, skipping SSL setup
    :information_source: Setting up SSL [skipped]
    ? Do you wish to set up Systemd? No
    Systemd setup skipped, reverting to local process manager
    :information_source: Setting up Systemd [skipped]
    ? Do you want to start Ghost? Yes
    :heavy_multiplication_x: Starting Ghost

And i am user petr in ubuntu terminal not root…

I did it on docker in windows a remotedocker extension by visual studio i can doqwnload file…and edit…but still i do not know where is url adress mysql ? Do you know where i can find phpmyadmin or something similar fo ghost ? port 3006 nothing show but page is working on port 3001…can you help how can i get back database sqll file ?

If you haven’t already seen it, here’s a thread in which the excellent mjw (a fellow volunteer community member) walks a user through fixing a very similar database setup problem:

Hope that helps!

p.s. MySQL typically listens at 3306, so I’m not where the 3006 reference is coming from, but that might be a docker thing?

Unable to connect

Firefox can’t establish a connection to the server at localhost:3006.

Where is phpmyadmin or some graphic user interface for database?

Did you install one?

Sounds like you’re trying to connect to localhost - is this install local? Is mySQL running?

Registration and admin working, mysql is working.Install is with docker. Do you knoe how i can download .sql file ? I listened, that maybe this do not have database, but i do not know if is it true ? I have files in extension in cisual stusdio code but i do not know, where is database file for download