Unable to start via Bitnami due to binary dependencies

I am currently using Ghost using AWS Lightsail.
But I forgot that I should not update the dependencies in Ghost by myself.

So I tried running sudo /opt/bitnami/ctlscript.sh start to get all three service (mysql, ghost, apache) up and it said (excluding the ‘mysql’ and ‘apache’ server is up part and passed check):

Message: The installed node version has changed since Ghost was installed.
Help: Run ghost update 4.7.0 --force to re-install binary dependencies.

and I have tried run ghost update 4.7.0 --force and it seems to not help anything. Nor ghost doctor.
Now my website (https://blog.sagelga.com) is in code 503.

So I tried starting it using ghost start. It doesn’t help and when using Bitnami tool, it still shows the service is down.
and also when I access it, it directs me to, which is port + private IP of the Ghost service.

I tried stop, restart from both Ghost CLI and Bitnami tool, and it seems not to help anything.

  • What’s your URL? This is the easiest way for others to debug your issue
    But the current website is on 503 due to issue(s)

  • What version of Ghost are you using?

  • What configuration?
    Attached a S3 storage and set to send mail via Mailgun

  • What browser?

  • What errors or information do you see in the console?

/opt/bitnami/mysql/scripts/ctl.sh : mysql  (pid 6387) already running
+ sudo systemctl is-active ghost_127-0-1-1
✔ Checking system Node.js version - found v14.15.4
✔ Ensuring user is not logged in as ghost user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
+ sudo systemctl is-active ghost_127-0-1-1
✔ Validating config
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
✔ Checking memory availability
✖ Checking binary dependencies
✔ Checking systemd unit file
Warning: Ghost is running with node v14.17.0.
Your current node version is v14.15.4.
✔ Checking systemd node version - found v14.17.0
One or more errors occurred.

1) Checking binary dependencies

Message: The installed node version has changed since Ghost was installed.
Help: Run ghost update 4.7.0 --force to re-install binary dependencies.

Debug Information:
    OS: Debian GNU/Linux, v10
    Node Version: v14.15.4
    Ghost Version: 4.7.0
    Ghost-CLI Version: 1.17.3
    Environment: production
    Command: 'ghost start --no-prompt'

Try running ghost doctor to check your system for known issues.

You can always refer to https://ghost.org/docs/ghost-cli/ for troubleshooting.
  • What steps could someone else take to reproduce the issue you’re having?
    Doing the npm upgrade in apps/ghost/htdocs/current (I think)

did you find how to solve this issue?

I’m not a user of bitnami, so this is just a guess.

It looks like you have either downgraded your Node version (Ghost running v14.17 - but OS reporting v14.15) - or you have two versions of Node installed.

You might try to debug:

node --version
which node
/usr/bin/node --version
/usr/local/bin/node --version

If you only have one node and its the old version - maybe upgrade to v14.17 - the easiest way IMHO to do this is using the NPM n module.

If you have two versions installed, remove the old one.