Suscribe is using http not https

Cant get membership to work Im on lightsail bitnami ive used the bncert tool to add ssl . but my mebership and signup still reference http:// where can I fix this

Welcome to the Ghost community, @stephen_ward.

It would be really helpful if you provided more information, e.g., the installation steps, any relevant messages during the installation, logs etc.

As a guess, I’d check the site URL is config.production.json, and make sure this is set for HTTPS.

thanks the installation was choosing ghost in lightsail - then I ran ```
sudo /opt/bitnami/bncert-tool

this is the config.production.json
"database": {
"client": "mysql",
"connection": {
"host": "",
"port": 3306,
"database": "bitnami_ghost",
"user": "bn_ghost",
"password": ,
"ssl": false
  "url": "",
"server": {
"port": 2368,
"host": ""
"mail": {
"transport": "Direct"
"logging": {
"transports": [
"process": "local",
"paths": {
"contentPath": "/opt/bitnami/ghost/content"

the error im getting
api.js:31 Mixed Content: The page at ‘’ was loaded over HTTPS, but requested an insecure resource ‘’. This request has been blocked; the content must be served over HTTPS.

The domain,, is redirecting to

Please share your Nginx configuration fro sites-available.

I cant find nginx on this server / apache ?

well almost everything working . the site is now using ssl . the only issue is the subscribe always fails
my current
“database”: {
“client”: “mysql”,
“connection”: {
“host”: “”,
“port”: 3306,
“database”: “bitnami_ghost”,
“user”: “bn_ghost”,
“password”: “9e58733b852d1a16f96b9904f0997ce58f3d05310a81bb23e380c5d8eb065633”,
“ssl”: false
“url”: “”,
“server”: {
“port”: 2368,
“host”: “”
“mail”: {
“transport”: “SMTP”,
“options”: {
“host”: “”,
“service”: “SES”,
“port”: “587”,
“auth”: {
“user”: “not shown for obvious reason”,
“pass”: “not shown for obvious reason”
“logging”: {
“transports”: [“file”]
“process”: “local”,
“paths”: {
“contentPath”: “/opt/bitnami/ghost/content”

Do you mean emails aren’t delivered?

NAME: EmailError
MESSAGE: Failed to send email. Reason: 140474876991424:error:1408F10B:SSL routines:ssl3_get
_record:wrong version number:…/deps/openssl/openssl/ssl/record/ssl3_record.c:332:

level: normal

“Please see Configuration - Adapt your publication to suit your needs for instructions on configuring email.”
Error: 140474876991424:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:…/

Im getting this error when trying to subscribe

Here is the log