Update has caused website to stop loading. Rollback does nothing to remedy

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? Local
  • What version of Ghost are you using? 3.28.0
  • What configuration? development
  • What browser? Chrome
  • What errors or information do you see in the console? No Error
  • What steps could someone else take to reproduce the issue you’re having?
  1. run version 3.28.0
  2. update to latest version using ghost update
  3. run npm install -g ghost-cli@latest because terminal says so

Shared with CloudApp

  1. reload the website and get dreaded ‘This site can’t be reached’ message
    Image 2020-12-23 at 9.21.43 pm

  2. Run Ghost start - Ghost is already started

  3. Ghost Doctor: output
    Image 2020-12-23 at 9.25.41 pm

  4. Still no luck getting it working in Chrome.

  5. Rollback using: ghost update --rollback
    Image 2020-12-23 at 9.26.55 pm

Now I’m in a pickle where I can’t get my local version running and I’m not sure what the next course of action is. Please help! :sweat_smile:

I’ve noticed when I run ghost ls I get this:

ghost-local │ /Applications/MAMP/htdocs │ 3.28.0 │ running (development) │ http://localhost:2370/ │ 2370 │ local

I’ve noticed the port number has changed(!) When I try this port number (2370) a ghost website loads… but not the one I’ve been developing on - It’s the default theme and content, and when accessing the /ghost directory I’m asked to create an account. Uh-ho!

My old port number was: 2368.

Have I lost everything with those 2 update commands above?

OK - Before attempting the update this I took a backup of:

  • content
  • The shortcut to ‘current’
  • versions
  • config.development.json

When I restore these files I’m still presented with the the fresh install and not by theme or content. As a test I opened in content/data/ghost-local.db and it’s definitely holding a copy of my data (thankfully!), but it’s oddly not recognising this, not my theme. I don’t want to progress with putting my details into /ghost as I don’t want to be too reliant on my backup, and I’m hoping there’s a config issue somewhere!

Another l thing to note, my backup directory doesn’t have a ghost.dev.db file, where as there are 2x .db files in the working directory.

OK - I’ve resolved it.

When I backed up the /data directory as part of /content the database was stored in a file called: content/data/ghost-local.db

When the rollback occurred I had a file called content/data/ghost-dev.db appear. This was a new file. So I renamed my backup file from /ghost-local.db to /ghost-dev.db and it worked.