Upgraded to latest ghost, now wont start, produces error log


#1

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? https://wyliebayes.com (but not working cause ghost wont start)
  • What version of Ghost are you using? 2.8.0
  • What configuration? not sure what this is asking
  • What browser? doesn’t matter, ghost wont start
  • What errors or information do you see in the console?
    Ghost will not start, points to a log file that contains:
    Debug Information:
    OS: openbsd, v6.4
    Node Version: v8.12.0
    Ghost-CLI Version: 1.9.8
    Command: ‘ghost start’
    Message: Ghost process exited with code: 0
    Stack: Error: Ghost process excited with code: 0
    at ChildProcess.cp.on (/usr/local/lib/node_modules/ghost-cli/lib/utils/local-process.js:56:24)
    at emitTwo (events.js:126:13)
    at ChildProcess.emit (events.js:214:7)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:198:12)

Any help resolving this error and getting my website back online would be super appreciated.


#2

I do not know what is the exact issue here. But probably you can rollback the changes to get your site back online.

Then install a local copy of a site backup and try to upgrade the Ghost to the latest version on that before you do it on the live server.

Rollback command
ghost update --rollback

or consider a force update (I do not recommend)
ghost update --force

Docs: https://docs.ghost.org/api/ghost-cli/update/

BTW, I came here to check if someone’s having issues after updating the ghost to 2.8.0. Before performing the update command on my server. :sweat_smile:


Updated to Ghost 2.8 get Url error
#3

Ghost Config:

{
“url”: “http://wyliebayes.com/”,
“server”: {
“port”: 2369,
“host”: “127.0.0.1”
},
“database”: {
“client”: “sqlite3”,
“connection”: {
“filename”: “/var/www/ghost/blog/content/data/ghost-local.db”
}
},
“mail”: {
“transport”: “Direct”
},
“logging”: {
“transports”: [
“file”,
“stdout”
]
},
“process”: “local”,
“paths”: {
“contentPath”: “/var/www/ghost/blog/content”
}
}


#4

LOL. well glad i could help. I also have a pretty unique server env so not sure if the same would affect you. Thanks for the suggestion,

i tried a rollback but now am getting:
It appears sqlite3 did not install properly when Ghost-CLI was installed. You can either uninstall and reinstall Ghost-CLI, or switch to MySQL.

I uninstalled / reinstall ghost-cli but it doesn’t not help, same problem on start and rollback.


#5

Wow… The “ghost update --force” worked!!! thanks truekasun!!!


#6

Glad it helped. :slightly_smiling_face: BTW, Everything’s working like a charm for me.


#7

I’m having the same error message updating from 2.2 to 2.80. It’s a bug or can be solved upgrading to Node 8?

Regards


#8

So when I initially experienced the problem i was still on Node 6.x, so i upgraded to node 8.12, but it did not resolve the issue. Only applying the --force flag on “ghost update” command resolved it.


#9

I did it like you and it’s working now.
Thanks.


#10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.