Updating of Ghost CLI or Ghost v4 taking forever

Hi, I am trying to update Ghost to the latest v5 but need to update to the latest v4 before I can do so. I tried updating but it seems like it is taking forever, have left it for over 2 hours has still not completed, have tried many times. Have then tried updating the Ghost CLI to the latest version sudo npm install -g ghost-cli@latest and the same thing is happening, It is taking forever to install with no luck or error message.

Has anyone experienced similar?

now am getting Command 'ghost' not found, did you mean: after I quit terminal during the update when trying to do anything

am getting the following when trying to update cli now:

Command 'ghost' not found, did you mean:

  command 'gost' from snap gost (2.11.2)
  command 'gfhost' from deb gfarm-client (2.7.15+dfsg-1)
  command 'host' from deb bind9-host (1:9.16.1-0ubuntu2.10)
  command 'qhost' from deb gridengine-client (8.1.9+dfsg-9build2)
  command 'xhost' from deb x11-xserver-utils (7.7+8)
  command 'rhost' from deb jdresolve (0.6.1-5.1)
  command 'khost' from deb knot-host (2.7.8-1)
  command 'gost' from deb gost (0.1.0+git20181204.5afeda5e-1)

See 'snap info <snapname>' for additional versions.