Upload of redirects and routes not longer possible since 5.1

Issue Summary
Since upgrade from 5.0 zu 5.1.0 it is no longer possible to upload routes or redirects.

Steps to Reproduce

With Ghost 5.0.1

  1. Go to Settings → Labs → Click on the upload button
  2. Click on one of the buttons for routes or redirect uploads
  3. Everything worked as expected, file upload windows opens

After upgrade to Ghost 5.1 this does not longer worked. Nothing happen after you clicked.
I tested it with two sites and two browsers (Safari und Firefox)


Setup information

Ghost Version
5.1.0

Node.js Version
v16.15.0

How did you install Ghost?
nginx, MySQL 8, ghost cli latest version

Provide details of your host & operating system
Debian 11

Database type
MySQL 8

Browser & OS version
Firefox 100.0.2 and Safari 15.5

Oh, so it’s not just me. On both self-hosted and Ghost(Pro).

1 Like

Also encountered this issue in version 5,1.

Had just moved the server and cannot upload routes and redirection anymore.

If you using ghost self hosted: Workaround for me is to do a ghost update --rollback
Then you will be able to import the routes/redirections again. And if you need 5.1 you can update again after import.

Thanks for the tip, Tim.

Unfortunately, in my case, I moved the server to a freshly installed Ghost instance with DigitalOcean. There is no previously installed version to rollback to.

I wonder if ‘updating’ to an older version will work.

The fix for this is already in. There should be a patch release soon.

Thanks @Kevin. 5.1.1 fixed it for me.

1 Like