Zapier and Cloudflare conflict

For some reason i cannot get zapier to connect to ghost. I am using the correct API and website url. I have even regenerated the API key just incase. When attempting to connect I get this error from zapier:

We hit an error adding your new account

authentication failed: Got 403 calling GET https://www.website.com/ghost/api/v2/admin/site/, expected 2xx.

  1. Make sure you click “Allow” or “Accept” on the permission popup
  2. Double check your Account has the correct permissions
  3. Check out our help docs for more information

I do not get any sort of permission pop. Any ideas? Thanks

I have started to have the same issues with my Ghost website. Has anyone else seen this issue before? As this is a 403 error am I right in assuming this is an authentication issue on Ghost website side rather than Zappier?

Has anything changed about your setup recently? If you’re self hosting: any changes to NginX config, CORS settings, new reverse proxy or changes to existing proxy, added Cloudflare or similar?

What Zap is this? v2 is pretty old…

I have not changed anything. How do i upgrade from v2?

Are you on ghost pro or self hosted or something else?

i am using the self hosted version

Ok, and what version of ghost? Do you have nginx set up or something else?

Version: 5.82.2

Im using cloudflare reverse reverse proxy

Has anyone been able to resolve this issue? I had been self-hosting with no problems for two years. Suddenly, all integrations stopped working when we upgraded to version 5.82. Nothing else was changed or touched.

I turned off the Cloudflare proxy to get it working but later enabled the proxy again, and it’s not working. Why would version 5.82 block this after so many years without issues with any other version upgrade?

I’ve seen a couple sites that use Cloudflare reverse proxy with new problems after the latest update. Not sure exactly what, and I’d have said it was only ghost pro sites affected. But that’s not you, so perhaps it’s coincidence?

1 Like

It’s puzzling indeed :)

Mystry solved… maybe.

Looks like Cloudflare BotFight mode is blocking Zapier.

Looks like you can create a custom WAF rule to exclude the zappier UserAgent, will test this out later.

1 Like

Just for anyone else having this issue and your on the Cloudflare Free Plan, it appears you are not able to skip Bot Fight Mechanics with a WAF custom rule on the Free Plan. Generally, you don’t need Bot Fight mode unless your site is under attack. For me the solution was to turn off Bot Fight mode in Cloudflare, issue not with Zappier or Ghost.

Rob_Wright I hope this resolves your problem

https://community.cloudflare.com/t/waf-bot-fight-mode-skip-rule-not-working-in-all-cases-on-free-plan/583219

Hello, you don’t need to disable the WAF.
In the Cloudflare side menu, in the Security option, select WAF, on the main screen, click on Tools, there, in IP range, country name, or ASN, enter this data: AS14618, action Allow and Add.
Try connecting Zapier again. This is a screenshot of the configuration.