I'm getting 503 error when I try to connect from my zapier account

I’ve set up a new site using Ghost. When I try to create and connect my zapier automation using the Admin API Key and Admin API URL, I get this error: authentication failed: Got 503 calling GET https://mydomain.com/ghost/api/v2/admin/site/, expected 2xx.

Can anyone please help me?

Generally, that means that your site is unreachable. I would check to ensure that the URL and admin key are correct.

1 Like

The site is reachable. I can visit my site, log in to my admin account, and make changes. I copied the URL and admin key from the Settings - Integrations - Zapier.

Are you able to share your site URL?

sure. https://narasimmantech.com

Hmm. I don’t see anything that would prevent this from working.

Have you tried deleting your Ghost connection in Zapier and re-adding it?

I couldn’t even connect.

Hey, I got it working :smiley: !

I used Postman, an open-source API testing software to test the API endpoint. When using IP address I got response code:200. But when I tested using the domain, I got 503. I use Cloudflare DNS for my Site. Cloudflare has a feature that proxies the actual IP of the origin server and forwards to a different IP. I turned off the feature ie., the ‘proxy option’, and when I tried zapier, the connection was successful. Parallelly I was also following live logs from the docker container of my ghost site.